Тёмный
Flutter Mapp
Flutter Mapp
Flutter Mapp
Подписаться
Flutter is a UI Toolkit built by Google which use Dart programming Language and is used to build any Mobile Apps. We code Flutter apps on the channel and make coding related videos.

0 Subs - 1st January 2021
10,000 Subs - 23 July 2021
20,000 Subs - 27 September 2021
30,000 Subs - 14 December 2021
40,000 Subs - 7 February 2022
50,000 Subs - 26 Mars 2022
60,000 Subs - 8 May 2022
70,000 Subs - 9 May 2022
80,000 Subs - 11 May 2022
90,000 Subs - 12 May 2022
100,000 Subs - 18 May 2022
Flutter Riverpod EASY Tutorial
8:16
5 месяцев назад
Flutter Provider EASY Tutorial
9:43
9 месяцев назад
Flutter Clean Architecture - Full Course
1:14:08
10 месяцев назад
Flutter Clean Architecture Visual Explanation
6:15
11 месяцев назад
Flutter Wrap Widget
0:34
Год назад
Flutter WillPopScope Widget
1:14
Год назад
Flutter Visibility Widget
0:43
Год назад
Flutter VerticalDivider Widget
0:32
Год назад
Flutter Transform Widget
0:27
Год назад
Flutter Tooltip Widget
0:23
Год назад
Flutter ToggleButtons Widget
0:37
Год назад
Flutter TimePicker Widget
1:13
Год назад
Flutter ThemeData Widget
1:13
Год назад
Flutter TextSpan Widget
0:45
Год назад
Flutter TextFormField Widget
1:38
Год назад
Flutter TextField Widget
0:57
Год назад
Flutter TextButton Widget
1:08
Год назад
How to use Hive with Flutter
13:38
Год назад
Flutter Text Widget
0:49
Год назад
Flutter Table Widget
1:12
Год назад
Flutter SafeArea Widget
0:22
Год назад
Flutter TabBar Widget
0:50
Год назад
Flutter SystemMouseCursors
0:44
Год назад
Flutter SwitchListTile Widget
0:33
Год назад
Flutter Switch Widget
0:22
Год назад
Flutter StreamBuilder Widget
1:23
Год назад
Комментарии
@user-ov5nd1fb7s
@user-ov5nd1fb7s День назад
Wtf is a guard clauses technique? It's called early return.
@SerdarPolat21
@SerdarPolat21 2 дня назад
where is domain layer?
@strictlyunreal
@strictlyunreal 2 дня назад
People are overusing this "return early" technique! I've even seen it in places where it's not needed at all and actually makes the code more difficult to maintain. I mean, people seem afraid to use the "else" keyword these days, and it's because of videos like this one, who call nesting bad. It's become ridiculous!
@abidibnazam4462
@abidibnazam4462 2 дня назад
Bro teaches flutter in less than a minute!!
@thefunnybuddy4138
@thefunnybuddy4138 2 дня назад
still too messy extract everything into another function and replace that body with a function call
@marufhassan634
@marufhassan634 3 дня назад
Can someone explain what Repositories (Entities) do and why then it goes to Repositories (Models)? Why doesn't it go directly from Repositories (Entities) to DataSource? What does Repositories (Models) do?
@Injabsful
@Injabsful 4 дня назад
no difference
@skytesports
@skytesports 4 дня назад
Can we give them height and width?
@Duck_side
@Duck_side 5 дней назад
So instead of nesting conditions, you're repeating code How is that cleaner?
@omarfarouk01
@omarfarouk01 5 дней назад
very useful content
@awesomemantroll1088
@awesomemantroll1088 5 дней назад
Store all conditions as booleans at the top of the code (you can cast if you need to). Use the booleans in the if-statements. Now there's no nesting, and there's also only one return value
@privilledge
@privilledge 5 дней назад
Great tutorial 👏, I highly recommend
@zero_asd
@zero_asd 5 дней назад
Ah the "six line if statements" hell😂
@legowyn24
@legowyn24 5 дней назад
Remember, there is no right or wrong method when it comes to coding. If it works that's what matters
@riantix
@riantix 6 дней назад
When you're trying to figure out alignment of your widgets (particularly, at 1:45:00), you can do Ctrl-Shift-P (not sure about mac) in VS Code and type "Toggle Debug Painting" to enable "Flutter: Toggle Debug Painting". This will let you see how big the columns/rows are, how much space they're using, why things are located at certain places and so on. Also thanks for the tutorial, it helps a lot!
@Dystisis
@Dystisis 7 дней назад
It's not that important for your code to be easy to read. Much more important that it runs well.
@mohammadfekri4987
@mohammadfekri4987 7 дней назад
tanx for video
@mohammadfekri4987
@mohammadfekri4987 7 дней назад
tanx for nice video
@prash_sh
@prash_sh 7 дней назад
Why not do (condition && condition && condition)
@imuw5408
@imuw5408 8 дней назад
Decorator pattern
@Me_Jawad
@Me_Jawad 8 дней назад
Simplify more &&
@KorruptorK
@KorruptorK 8 дней назад
While nested ifs is never a solution, having a lot of return blocks is not that good either (not sure as of right now, but Sonar also had a "clean code" rule that enforced a single return value per function, and I also recall cyclomatic complexity was affected by the amount of returns. I'd rather have a single "isUserLoggedInAndAdmin" which wraps all the required logic (and can be used everywhere else) abd a single if/else block. Much more readable and easier to debug as specific logic is wrapped where is actually belongs, imho You could even have two functions if you want to enforce maximum modularity: "isUserLoggedIn" and "isUserAdmin". This may look overkill because your example is using basic booleans, but try fetching those statuses out of a token or a db every time on your code and it quickly becomes a copy/paste smell on unexperienced hands..
@karansuthar3337
@karansuthar3337 8 дней назад
now i know more of what is possible in flutter. nice work👌
@generallhud
@generallhud 8 дней назад
This code still ugly, you can use &&, or why the hell you need to check if logged in while you are able to check user role?
@jayabegglen4665
@jayabegglen4665 9 дней назад
Orrrrr: If (WiFi and login and admin): //do stuff Else //do something else
@ThomasVWorm
@ThomasVWorm 9 дней назад
What about: getCaffeine(type){ return (type == 'Coffee') ? '95 mg' : (type == 'Redbull') ? '147 mg' : (type == 'Tea') ? '11 mg' : (type == 'Soda') ? '21 mg' : 'Not Found'; }
@azizmayy8010
@azizmayy8010 9 дней назад
dart library 'dart.ui' is not available on this platform ????? what should i do i m really annoyed
@ThomasVWorm
@ThomasVWorm 9 дней назад
This example shows, that the language lacks the "unless" keyword.
@joeydicastro
@joeydicastro 10 дней назад
Amazing, thank you.
@PlayBASIC-Developer
@PlayBASIC-Developer 10 дней назад
Its funny how often wrong gets redefined in programming. Way...back When I was a kid, functions have a single exit point. So you had to nest by definition.
@hoangkietvo5790
@hoangkietvo5790 10 дней назад
Thanks for this toturial
@_Nitrous_
@_Nitrous_ 11 дней назад
1.this is just an example, everybody need to calm down with the "security" stuff... 2.early return is not necessarily a better option 3.try to avoid big nested IF statement.. obviously 4.nobody cares about your unit test, except maybe at university 5.Vive le Quebec !!
@user-ou7hd1zi2i
@user-ou7hd1zi2i 11 дней назад
I really appreciate you guys taking your time to explain this to us. Thanks so much.🙏🏾🙏🏾
@MarcosOliveraZapata
@MarcosOliveraZapata 11 дней назад
That is poor software design, not following OOP principles, SOLID, etc.
@amairanifox1332
@amairanifox1332 11 дней назад
Fine
@user-wv9pw9tq1g
@user-wv9pw9tq1g 11 дней назад
Can’t say for RefactorGPT to crawl through my code and do this + security all for me 😂
@xushidjonismatov4181
@xushidjonismatov4181 11 дней назад
rahmat
@codewithsanta1054
@codewithsanta1054 12 дней назад
Please create video for flutter web nav menu with submenu like we use in bootstrap
@tiziprince
@tiziprince 12 дней назад
Thank you so much. You made me understand Flutter within a twinkle of an eye. God bless!!!
@UltraFiero
@UltraFiero 12 дней назад
Better yet, use an assertion and handle the exception. Why have a function that is supposed to do something and just silently fails while printing a log. Thats just bad code right there. Best bet here is 3 assertions and then a if (wifi && login && admin) to further protect it
@syzore2
@syzore2 12 дней назад
Is it possible to change the buttons text? And is it possible to close all the steps? (too bad the current step is not nullable..)
@ancienttech4603
@ancienttech4603 13 дней назад
I guess you've never heard of, "one way in, one way out." There is also the problem of lazy coders throwing a quick line of code at the end of a function, thinking it will be run when the function exits. There are uses for early returns, but I don't think readability is a good one.
@easyelectronics4364
@easyelectronics4364 13 дней назад
Legends think of function pointers💪💪
@jessejackman9706
@jessejackman9706 13 дней назад
So its the same
@FranklinLokki
@FranklinLokki 13 дней назад
don't you have a french channel for the same content ?
@aldoalexisurtusuasteguicar7493
@aldoalexisurtusuasteguicar7493 14 дней назад
very well explanation of clean architecture using a cone. thank you!
@KosmicK1
@KosmicK1 14 дней назад
This video is wrong
@7atab
@7atab 14 дней назад
I'm not a programmer but I know for sure that must be there's "or" "and" "not"statement?